New virtualmin-config package version 6.0.17/6.0.18 available

31 news today, 411 news this week, 4520 in total.
Date

Forums: NewsHowdy all,

I've just rolled out version 6.0.17 (for CentOS) and 6.0.18 (for Debian 8 and 9 and Ubuntu 16.04 because I found I missed one issue that this release was supposed to fix for those distros immediately after rolling 6.0.17) of the virtualmin-config package for systems installed from the Virtualmin 6 installer. This package is not yet useful on systems installed with the old installer, so can be ignored if your installation was performance with any version of install.sh before 6.0.0.

Anyway, this update fixes the following issues:

  1. ProFTPd configuration isn't quite right in a couple of different ways. If you have no TLS or FTPS support, updating and running the command suggested below will fix it.
  2. Fail2ban with Firewalld is kinda messed up on Debian/Ubuntu. This isn't the fault of the installer or virtualmin-config; it's a bug in the fail2ban systemd unit on those distros. But, this version should fix it. The symptom of this is fail2ban refusing to start.

OK, so, to fix these problems, update to 6.0.17 or 6.0.18 (it'll show up in the Virtualmin dashboard):

On CentOS or Debian or Ubuntu, if you ant TLS and SFTP support to work in ProFTPd:

# virtualmin config-system --include ProFTPd# systemctl restart proftpd

And, on Debian or Ubuntu (not needed on CentOS, as it already works) to make fail2ban able to start:

# virtualmin config-system --include Fail2banFirewalld# systemctl restart fail2ban

Older non-systemd distributions should not run this latter command (there is no Firewalld on non-systemd systems...I dunno what'd happen, but it certainly wouldn't fix anything).

As always, let us know about problems. I fix any problem I can identify, but our software surface area is so huge these days with so many supported distributions it can be really hard to know when there's a problem until folks tell us.

Cheers,
Joe